traveler hum

traveler hum

Postby madman366 » Sun Sep 03, 2017 5:33 am

Hello everyone I have had a problem with hum on my traveler2 table for awhile and its driving me nuts. I dont think it is feedback from speakers all i have to do is have needle on record without it spinning and if i turn volume up to about 3 i get woofer pump. Same goes for playing lps but if arm is resting in support i can turn volume all the way up with no hum so i dont think its the preamp. I am using a dynavector 20x2l with a dynavector mk2 preamp. I bought the cart used could it be damaged? I also have a new power line/breaker in panel and everything is on it so i dont think its any kind of ground loop. I am using a restored sansui g9000 for amp which has a subsonic filter but i dont think it works with aux input only phono. Any info would be helpful thx Dennis
madman366
Newbie
 
Posts: 6
Joined: Sat Dec 19, 2015 10:36 am

Re: traveler hum

Postby madman366 » Sun Sep 10, 2017 2:48 am

Well found the problem it was the cart. Put on a grado black i had and no more woofer pump
madman366
Newbie
 
Posts: 6
Joined: Sat Dec 19, 2015 10:36 am

Re: traveler hum

Postby tom collins » Sun Sep 10, 2017 7:40 am

what brand and type was the cartridge that made noise?
TNT6HR, rim drive, superplat, outer ring + center weight, 12.0 arm, base and 12.7 armwand, SDS, SRA platform; Delos, Zu, Grado ME+ carts; Musical Surroundings Nova 2, custom SUT; Cary 30i prototype EL34 integrated amp; Devore Gibbon 8 speakers; PSB sub.
tom collins
Senior Member
 
Posts: 371
Joined: Mon Aug 25, 2014 10:30 pm

Re: traveler hum

Postby Gary1955 » Sun Sep 10, 2017 10:27 am

He said it was a Dynavector 20x2L.
VPI HR-X rim drive w/magnetic drive platter, 3D Ref. 12" tonearm, Lyra Titan-i cartridge, Graham Slee Reflex M & Elevator, tri-amped horn system w/electronic crossover.
Gary1955
Senior Member
 
Posts: 488
Joined: Sun Sep 21, 2014 10:45 pm

Re: traveler hum

Postby brianmch » Tue Sep 12, 2017 10:53 am

I've been having some hum issues with my Classic using a Dyna 20xl2. I'll try something else to see if it helps.
brianmch
Jr. Member
 
Posts: 17
Joined: Tue Dec 22, 2015 4:53 pm

Re: traveler hum

Postby Dorian » Tue Sep 12, 2017 12:21 pm

Don't try an Ortofon 2M Black - mine hummed like crazy.
VPI Prime #959 | SoundSmith MIMC Star | iFi iPhono v2 (Herron VTPH-2A ordered) | Primaluna DiaLogue Premium Integrated | KEF LS-50s | Phoenix Eagle & Roadrunner | Stillpoints ULPI | Boston Audio Mat2 | Audio Sensibility Cables | Sound Anchor Stands
User avatar
Dorian
Senior Member
 
Posts: 658
Joined: Tue Aug 26, 2014 2:14 pm
Location: Westchester County, New York


Return to Support Forum

Who is online

Users browsing this forum: Google [Bot] and 1 guest

x