"Early Cyclone" platter fail and fix

"Early Cyclone" platter fail and fix

Postby kurtster » Sat Sep 01, 2018 9:34 pm

The past week the platter spindle fitting that attaches to the motor drive shaft of my "Early Cyclone" as I see it distinguished here, came loose and fell down and stopped spinning. I did some searching and found one other owner with the same problem. The set screw came loose. Apparently no one used any lock tite during the initial assembly. It took 2 years to come loose and fail, but it was a major disappointment for something so expensive, yet well built.

I took it apart to see what was up and did find it extremely well built and thought out. I had it apart once before to clean out the drain hole in the tank when it clogged which was tons of fun, but it is what it is. I do understand the high cost of limited run metal parts fabrication, so I get the cost, etc. Saw the set screw and did a re tighten with lock tite, put it back together and found out that I had not set it high enough for the platter to clear the motor mounting screws. Grrr. Took it apart, again, figured out the height needed to clear the screws. It held for about 10 minutes and then dropped down the shaft making it inoperable.

Now I'm getting pretty angry. I finally figured out what was wrong and had to really do a lot of work to get the set screw out. Went to bed upset wondering how I was going to keep the platter spindle from falling again. It seems that the spindle shaft is hollow so the set screw does 100% of the work keeping it elevated to the proper height on the motor shaft. I was wondering what to put up in the shaft to keep it at the proper height and relieve the set screw from doing all the work. Wooden dowel, stacked washers ? That required taking the spindle to Home Depot and rummaging around looking for stuff. Then I thought, find a plastic coat hanger of the proper diameter and cut it to the proper length. That is what I did.

Initially the length was around 11 mm. When I went to test things out, the platter was too high for the wand to be able to lock in place during the counterclockwise revolutions. I cut it down to 7 mm and took it apart one more time because I could no longer get to the set screw from the outside of the case. That height ended up being fine. The spindle also seems to be very tight on the motor shaft with no play at all in any direction. It will be a bit of trial and error depending on the diameter of what you use inside the shaft as it is tapered at the top. But all is well and I love my Cyclone. Probably the single most important part of my audio food chain.

I hope that these design oversights have been corrected with the release of the "New Cyclone". So if you have an "Early Cyclone" and have this kind of platter spindle failure (seems that it is only a matter of time), I can save you a lot of grief with this story.

Now I have to wonder what lies ahead for me when I need another vacuum tube holder that goes into the tank. I hear that the replacements are too big and a retrofit is required. Perhaps a recall on this and free part ? And also wonder what are the primary differences between the Early Cyclone and the New Cyclone.

Hope this helps any Early Cyclone owner down the road.

Cheers !!
Kurt
kurtster
Newbie
 
Posts: 3
Joined: Sat Sep 01, 2018 8:46 pm
Location: Northeast Ohio

Return to Support Forum

Who is online

Users browsing this forum: Bing [Bot] and 5 guests

x